Announcement

Collapse
No announcement yet.

"Failed to open config key."

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Failed to open config key."

    That's the error message I get when I try to install SPTD 1.24 in x64 Windows.
    I actually have no clue what may cause it, since it worked fine until yesterday, then Alcohol just stopped loading its drivers.
    Is there anything I can do, except a full reinstall? (Although that would not be too much of a problem, since I kind of to those once in a week, or at least almost)

  • #2
    Did you check the related info in the support FAQ yet:
    http://duplexsecure.com/support/

    Comment


    • #3
      Actually I'm having the same problem. On the start-up the following system error is being logged:

      Event Type: Error
      Event Source: sptd
      Event Category: None
      Event ID: 4
      Date: 28.07.2006
      Time: 19:48:52
      User: N/A
      Computer: NEW
      Description:
      Driver detected an internal error in its data structures for .

      For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
      Data:
      0000: 00 00 00 00 01 00 52 00 ......R.
      0008: 00 00 00 00 04 00 04 c0 .......
      0010: ae 00 00 00 00 00 00 00 .......
      0018: 00 00 00 00 00 00 00 00 ........
      0020: 00 00 00 00 00 00 00 00 ........

      Also, when trying to open sptd-related registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd\Cfg I'm getting consistent error notice: "Cannot open Cfg: Error while opening key".
      The issue appeared after I did system repair (repair option in one of the later steps of windows setup preparation). As a result Virtual Daemon (v4.03x86) cannot start with message:

      Initialization Error: This program requires at least Windows 200 with STPD 1.24 or higher. Kernel Debugger must be deactivated.

      I'm using and administrative account, so I don't think the problem is the lack of permissions. Also, I can't set the permissions for this registry key. Reinstallation attempt of 4.03x86 fails with the message mentioned in the topic. Any ideas how I can remove the key and reinstall SPTD?

      Forgot to add - no antivirus is installed. OS is WinXP Pro w/out any service packs. Before the crash that required to use system repair everything worked fine and it's not a virii - system was quite fresh and being scanned several times with Dr.Web CureIt standalone scanner and is being protected by Outpost firewall.
      Last edited by _Lynx; 07-28-2006, 11:32 PM.

      Comment


      • #4
        Delete/rename sptd.sys and reboot, then remove the key from registry and re-install.

        Comment


        • #5
          Thanks, helped!

          Comment

          Working...
          X