Announcement

Collapse
No announcement yet.

Sptd

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sptd

    why the SPTD 1.69 downloaded from Duplexsecure show application not valid in Win32 ?

  • #2
    Please re-download the installer, it seems to be corrupted.

    Comment

    Working...
    X