Announcement

Collapse
No announcement yet.

sptd.sys doesn't load, reinstall useless

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • sptd.sys doesn't load, reinstall useless

    Hello everybody,

    I’m using SPTD together with Deamon Tools Lite on my Win7 x64 machine (I’m using M$ SE as antivirus, no other antivirus or ad-/spyware detection program installed). A few days ago, dtools stopped working without me having changed anything. After some research I found out that the problem is a SPTD-error (see after description), which is recorded in my system event log (one error for every system boot). So I tried to reinstall dtools at first, without any positive result. After that I tried to install the SPTD only (newest version from DS webpage, 1.75), reboot, but same error. The installer also gives me the message, that “No SPTD version was detected”. Now I disabled SPTD via regkey, reboot, deleted sptd.sys and all regkeys, reboot, reinstalled - as recommended by digger here in the forum. Still same problem.

    So I came to the conclusion, that I have to bother you with the event log error:

    Protokollname: System
    Quelle: sptd
    Datum: 03.12.2010 09:38:15
    Ereignis-ID: 4
    Aufgabenkategorie:Keine
    Ebene: Fehler
    Schlüsselwörter:Klassisch
    Benutzer: Nicht zutreffend
    Computer: G

    Beschreibung:
    Der Treiber hat einen internen Fehler in seinen Datenstrukturen für festgestellt. (internal driver error in datastructures)
    Ereignis-XML:
    <Event (...removed due to insufficient rights...)>
    <System>
    <Provider Name="sptd" />
    <EventID Qualifiers="49156">4</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2010-12-03T08:38:15.671875000Z" />
    <EventRecordID>30948</EventRecordID>
    <Channel>System</Channel>
    <Computer>G</Computer>
    <Security />
    </System>
    <EventData>
    <Data>
    </Data>
    <Binary>000000000100000000000000040004C0ED00000000 00000000000000000000000000000000000000</Binary>
    </EventData>
    </Event>

    Binäre Daten:
    In Wörtern

    0000: 00000000 00000001 00000000 C0040004
    0008: 000000ED 00000000 00000000 00000000
    0010: 00000000 00000000

    In Bytes

    0000: 00 00 00 00 01 00 00 00 ........
    0008: 00 00 00 00 04 00 04 C0 .......À
    0010: ED 00 00 00 00 00 00 00 í.......
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........

    Hopefully, you’ll be able to help me.

    Thank you very much for your efforts in advance.

    Kind regards,
    T. W.

  • #2
    Disable debugger. If you enabled debugging in Windows, disable it with bcdedit /debug off.

    Comment


    • #3
      Thank you very much, Digger! You're my hero of the day! (Uh, hope that doesn't sound gay)

      Although I didn't consciously activate the kernel debugger, this was the quest's solution! Had to change to the "hidden" admin account in Win 7, start cmd.exe and enter digger's command "bcdedit /debug off". After a system reboot I was able to reinstall SPTD properly!

      Thanx again!!! :-)

      Comment

      Working...
      X