Announcement

Collapse
No announcement yet.

SPTD.SYS not created after installation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SPTD.SYS not created after installation

    Hello,
    I've been trying to install the latest version of SPTD on Windows 7 64bit system. Installation went ok and asked for restart. After restart sptd installator shows - no sptd detected please install.
    I've checked registry and it shows the sptd section correctly.
    But in event log it shows sptd.sys is missing.
    Checked the \system32\drivers folder and the dll file was not there.
    I've tryed to install it in windows safe mode but it still doesn't create the dll file.
    Any ideas how to force windows to accept the dll file?
    Thanks

  • #2
    Which dll file do you mean? There should be sptd.sys in system\drivers directory.
    Please post the eventlog message, incl. all error bytes (Details tab).

    Comment


    • #3
      What's your security software?

      Comment


      • #4
        Sorry, my mistake. I ment sys files. Here is my event log error.

        - <Event xmlns="">
        - <System>
        <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />

        <EventID Qualifiers="49152">7026</EventID>

        <Version>0</Version>

        <Level>2</Level>

        <Task>0</Task>

        <Opcode>0</Opcode>

        <Keywords>0x8080000000000000</Keywords>

        <TimeCreated SystemTime="2011-02-03T20:44:43.633626500Z" />

        <EventRecordID>12926</EventRecordID>

        <Correlation />

        <Execution ProcessID="536" ThreadID="540" />

        <Channel>System</Channel>

        <Computer>Rada-PC</Computer>

        <Security />

        </System>


        - <EventData>
        <Data Name="param1">cdrom sptd</Data>

        </EventData>


        </Event>


        I use Comodo antivirus software. I now about the issue with anti-software
        causing troubles installing sptd, this is why I tried install it in safe mode, but with the same resault. Any ideas are welcomed.

        Comment


        • #5
          There seems to be a problem with Comodo, the Defense+ function interferes, thus it is suggested to disable the service, and reboot - or use another antivirus software.

          Comment


          • #6
            Thank you for your reply.
            I'll try to install it with Comodo disabled and see if it helps.
            I'll let you now with the result.

            Comment


            • #7
              Well I managed to install the sptd or the system thing's so - when I run the installer it shows the 1.76 version is installed, but there is still no sptd.sys file on the computer, so I'm unable to use advanced emulation of daemon tools at all.
              In the registry part of sptd it shows \SystemRoot\System32\Drivers\sptd.sys,
              but no file of this name is on the computer.
              Any ideas why the installer things everything is ok, but the file is missing?

              Comment


              • #8
                Did you deactivated Defense+ with the option which requires a reboot?
                The problem causing service is still active even when you disable Comodo.

                Comment


                • #9
                  Yes. I completely uninstalled Comodo off the system, did several restarts and after that tried to install sptd.

                  Comment


                  • #10
                    Just for info every try to install sptd generates event log error of :

                    Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface.

                    Comment


                    • #11
                      If SPTD is detected by installer, it is installed correctly and running. Did you try to install any software using SPTD layer yet?
                      Regarding the Volume Shadow Copy Service error we couldn't reproduce it, do you experience any problems regarding it?

                      Comment


                      • #12
                        Yes. I tried to install Daemon Tool and wanted to use Advanced Emulation function, but when I check the box to use AE it says it is going to install sptd driver and restart. But after restart the checkbox is unchecked again and I can do it all over again.

                        I'm not experiencing any problem with Volume Shadow Copy Service. The error shows up only when I try to install sptd driver.

                        You said that there shoud be sptd.sys file in drivers directory but the file is not there. Does the installer check for sptd.sys existance? Can there be connection between Volume Shadow error and sys file missing?

                        I thing the impossiblity to use AE in Daemon is due the lack of sptd.sys file on the system. Any other ideas?

                        Comment

                        Working...
                        X