No announcement yet.

How to uninstall SPTD for dummies

  • Filter
  • Time
  • Show
Clear All
new posts

  • How to uninstall SPTD for dummies


    I've been working with an Administrator at Tech Support Guy on a problem with my home computer. I have a Dell 4500 running XP SP2 and have no idea what I'm doing.

    I was advised to come here and request instructions on how to uninstall SPTD so that we can clear up a deeper problem on the machine.

    Can you assist me with this?

    Thank you.

  • #2
    If Windows is still working you can either download the installer (, run it, select "Uninstall", and reboot,
    or open registry editor (regedit), go to
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd
    and change the "Start" value to 4, and reboot.
    If Windows doesn't start anymore, boot with a Windows CD into recovery console, log-in to your Windows installation (requires Administrator password), and enter "disable sptd", then exit to reboot.


    • #3
      When I run regedit, under spdt, I get 4 items:

      (icon ab) (Default) REG_SZ (Value not set)
      (icon ab) 0 REG_SZ ROOT\LEGACY-SPTD/0000
      (icon 011/110) Count REG_WORD 0x00000001(1)
      (icon 011/110) Next Instance REG_WORD 0x00000001(1)

      "Start" not found. I am not very familiar with all this. Can you provide guidance?


      • #4
        Have tried several times to download and run the installer from the DuplexSecure site, but end up getting an error message that says there is a higher version present. There is no other option other than to click on the OK button in the message box. Using advance search, I can not find any version higher than V162 on my machine.


        • #5
          Please check download page again for 1.79, there was an error on server.


          • #6
            Downloaded it and clicked on "Run". Nothing else happened. Went to my download directory and found it, double-clicked on it and got the following error message:

            C:\Documents and Settings\Don\My Documents\Downloads\SPTDinst-v179-X86 is not a valid WIN 32 application.

            What next? Thank you.


            • #7
              Try to re-download it, seems the download is corrupted.
              Ensure it has a file size of 592952 bytes.

              In registry editor ensure you look at ControlSet hive, not ControlSet001, etc.


              • #8
                Did that. Got the full 580. I think I was able to uninstall SPTD. When I went to my downloads directory and found the download after rebooting, Clicking on it brought forth a box that indicated there was no version of SPTD on the machine and would I like to install it. Thank you.