No announcement yet.

Alcohol 120% / SPTD problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • Alcohol 120% / SPTD problems

    I noticed one of my programs, that need Alcohol 120% running for it's RPMS emulation, would not load. The disc was not scratched, so fired up Alcohol 120% - I don't remember what it said exactly, but it said the driver wasn't loaded.

    I Googled, and some articles said to update the SPTD driver - so I did, with no joy at all!

    So I tried to uninstall Alcohol, so I could reinstall it. I couldn't find it in Add/Remove Programs, so used Revo Uninstaller's "Hunter" to uninstall Alcohol 120%. Restarted and tried to reinstall Alcohol, only to get this message right after pressing Next at the agreement screen: "Interal setup error. Contact support."

    Everything my Googling comes back to, is SPTD. And it looks like I am one of many people having this very same problem.

    So the primary reason I am here is to find out how to fix this problem. I've lost count how many times I've rebooted, reset permissions on SPTD registry keys. Frankly, this is beyond a joke. And there's not even a decent SPTD clean up tool, because the one I tried said SPTD was not installed!

    Secondly - what on earth are DuplexSecure playing at? It is clear with so many users having this very problem, that something MUST be wrong with their software. Alcohol and SPTD work fine when they are running - but when they stop, it is a complete disaster!

    My OS is Windows 7 Ultimate x64, with 4gb of RAM and a E8400 CPU on an Asus motherboard - all running at stock.

    I look forward to some answers and resolutions!

  • #2
    Such an internal setup error usually points to either corrupted SPTD configuration or some software (anti-virus, security, etc., or virus/trojan) messed up registry access.
    So first of all check system eventlog (execute eventvwr.msc) regarding SPTD error messages, post the entire error including all error bytes (see Details tab).
    If you use any kind of security software (e.g. Comodo), it would help to know which software you have installed.
    Regarding the removal and re-installation of SPTD layer it is actually quite easy, if you follow the steps precisely, especially the required reboots.
    1. Open registry editor (regedit), go to
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd
    change the "Start" value to 4, and reboot,
    2. open registry editor again, enable all permissions of sptd\cfg key, then delete entire sptd key, and reboot again (important!),
    3. download/use SPTD stand-alone installer (, the x64 version in your case, run it, select "Install", and reboot,
    4. execute SPTD installer again - it should report SPTD layer installed - if it doesn't do NOT attempt to install any software using SPTD layer (like Alcohol), check system eventlog (see above).


    • #3
      Thanks for taking the time to reply, Digger! Unfortunately nothing you said was valid, as the SPTD keys were already deleted by myself with that method.

      After much rooting around, I saw one suggestion on a forum to uninstall Spybot Search & Destroy - I didn't think this would apply to me, and I don't have the realtime monitoring on. But Spybot S&D still like to run it's service on startup. Anyway, after uninstalling Spybot S&D I was able to install Alcohol 120% with no problems.

      The program I used needed to be reinstalled - but not such a big deal, compared to the hours I've spent trying to sort SPTD out!!

      In hoping that my post will help somebody: If you have any problems with SPTD/Alcohol installation, use Revo Uninstaller, make sure you completely uninstall any spyware/adware and/or antivirus programs.


      • #4
        this completely looks like an advert for that crap revo uninstaller software.