Announcement

Collapse
No announcement yet.

SPTD Doesnt install!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    See this thread: http://forum.duplexsecure.com/showthread.php?t=12

    I had exactly the same problem some months ago. I have now a new Dell laptop, also from work, the same problems. I couldn't be bothered going through it all again, so I have an old (v3) version of Daemon installed.

    However, you might want to read through the thread because I did notice that I could get Daemon tools v4 to work using "run as".

    Comment


    • #32
      same here

      well, 1.39 on vista would't even let vista boot , or go into safe mode. Now, with 1.40, it just won't install. fresh install of vista, one care, office 2007, that's about it. Infinite loop as described above.

      Comment


      • #33
        By the way, I'm running everything as Administrator.

        Comment


        • #34
          Please post the binary bytes of SPTD related error message in system eventlog.

          Comment


          • #35
            There are no error messgaes in Event Viewer, so I cannot post any info from there.

            Comment


            • #36
              i have same problem... stpd 1.45, vista 64bit RTM Ultimate

              Code:
              Log Name:      System
              Source:        Service Control Manager
              Date:          26.2.2007 17:52:22
              Event ID:      7026
              Task Category: None
              Level:         Error
              Keywords:      Classic
              User:          N/A
              Computer:      nitemare-vista
              Description:
              The following boot-start or system-start driver(s) failed to load: 
              sptd
              Event Xml:
              <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
                <System>
                  <Provider Name="Service Control Manager" Guid="{555908D1-A6D7-4695-8E1E-26931D2012F4}" EventSourceName="Service Control Manager" />
                  <EventID Qualifiers="49152">7026</EventID>
                  <Version>0</Version>
                  <Level>2</Level>
                  <Task>0</Task>
                  <Opcode>0</Opcode>
                  <Keywords>0x80000000000000</Keywords>
                  <TimeCreated SystemTime="2007-02-26T16:52:22.000Z" />
                  <EventRecordID>2741</EventRecordID>
                  <Correlation />
                  <Execution ProcessID="0" ThreadID="0" />
                  <Channel>System</Channel>
                  <Computer>nitemare-vista</Computer>
                  <Security />
                </System>
                <EventData>
                  <Data Name="param1">
              sptd</Data>
                </EventData>
              </Event>
              Code:
              [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sptd]
              "Type"=dword:00000001
              "Start"=dword:00000000
              "ErrorControl"=dword:00000001
              "Tag"=dword:00000007
              "ImagePath"=hex(2):53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,44,00,\
              72,00,69,00,76,00,65,00,72,00,73,00,5c,00,73,00,70,00,74,00,64,00,2e,00,73,\
              00,79,00,73,00,00,00
              "Group"="Boot Bus Extender"
               
              [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sptd\Enum
              "Count"=dword:00000000
              "NextInstance"=dword:00000000
              "INITSTARTFAILED"=dword:00000001
              edit: there's also a key named Cfg visible, but if i try to export it says "The selected branch does not exist..."
              WTF???
              Last edited by nite23; 02-26-2007, 05:05 PM.

              Comment


              • #37
                We need the binary bytes of the eventlog error message, not the contents of the registry keys.

                Comment


                • #38
                  Same issue here: installation program makes a cycle of reboots, every even run says that it will continue after reboot, every odd run says suggests to disable current service and retry after reboot.

                  Okay. I've got a WinXP SP2 Russian install with all security updates, vendor hardware drivers. Almost no additional software. The box is a PC, mainboard Asus A7V8X, a SCSI controller Adaptec AHA-2940. One SCSI HDD, two SATA HDDs. The boot disk is a SCSI one, the %systemroot% is on SATA one.

                  Two reproduce the issue in clean way, I have booted to safe mode and wiped all remains of SPTD installtion from registry. Then booted in normal way and run installtion of Daemon Tools - daemon408-139-x86.exe, that contains SPTD 1.39. I've run it via "Run As...", choosing builtin administrator account.

                  After acking EULA installation program said, that it will continue after reboot. After reboot I've run daemon408-139-x86.exe again via "Run As...". It displayed a message box:

                  "Current SPTD installation cannot be validated by setup. It is recommended to disable SPTD service and rerun setup after reboot. Do you want to disable SPTD service now? "OK", "Cancel""

                  If I press OK, after reboot the mentioned cycle will start again.

                  And now in the system log I have three identical error messages from sptd service.

                  ID 4, error in internal driver structures
                  Code:
                  0000: 00 00 00 00 01 00 52 00   ......R.
                  0008: 00 00 00 00 04 00 04 c0   .......
                  0010: a3 00 00 00 00 00 00 00   .......
                  0018: 00 00 00 00 00 00 00 00   ........
                  0020: 00 00 00 00 00 00 00 00   ........

                  Comment


                  • #39
                    Hello. I'm facing same problem. I tried to install last version of Alcohol 120% (1.9.6.4719). It also loops (reboot before continiune, again reboot and again). I went to their support forum ( http://forum.alcohol-soft.com/index.php?showtopic=25165 ). They suggested to go here and read more. Also they noticed about "rd0". Ok, then I looked in system registry and found this key "rd0". I deleted it, without reboot run alcohol setup and got same problem. It asked to reboot again. Before reboot I noticed that key "rd0" had appeared again. After reboot it didn't disappeared.

                    After that i downloaded SPTDinst-v142-x86 and run it. It said that no SPTD version was detected. I pressed Install button - after installation it offered me to reboot. I have rebooted my computer. Run SPTD installation again - and again it said that no drivers blah blah blah. Install, reboot, nothing. Installation of alcohol after all is same. I runing Windows Vista 32 bit Ultimate. Can you help with this problem please?

                    Sorry for my english.

                    Comment


                    • #40
                      glebius:
                      Please install SPTD layer v1.42, then check eventlog again. If you still get that error please contact our support by mail (support@duplexsecure.com).

                      Zoomer:
                      Please check system eventlog for error messages regarding SPTD layer (execute eventvwr.msc), post the whole error message including all binary bytes.

                      Comment


                      • #41
                        Sorry I forgot about events. There is one:
                        (error in internal driver structures)
                        - System

                        - Provider

                        [ Name] sptd

                        - EventID 4

                        [ Qualifiers] 49156

                        Level 2

                        Task 0

                        Keywords 0x80000000000000

                        - TimeCreated

                        [ SystemTime] 2007-02-26T22:07:28.640Z

                        EventRecordID 8262

                        Channel System

                        Computer Zoomer-PC

                        Security


                        - EventData


                        000000000100000000000000040004C0B80000000000000000 000000000000000000000000000000

                        Binary files:


                        Words:

                        0000: 00000000 00000001 00000000 C0040004
                        0008: 000000B8 00000000 00000000 00000000
                        0010: 00000000 00000000


                        Bytes:

                        0000: 00 00 00 00 01 00 00 00 ........
                        0008: 00 00 00 00 04 00 04 C0 .......
                        0010: B8 00 00 00 00 00 00 00 .......
                        0018: 00 00 00 00 00 00 00 00 ........
                        0020: 00 00 00 00 00 00 00 00 ........
                        By the way I'm using russian version of Windows Vista if this have some meaning.

                        Comment


                        • #42
                          Originally posted by Digger
                          glebius:
                          Please install SPTD layer v1.42, then check eventlog again. If you still get that error please contact our support by mail (support@duplexsecure.com).
                          I've booted into safe mode, cleansed the registry, then rebooted and installed SPTD v1.42. This helped. No error messages in eventlog. Thanks!

                          However, if I try to install latest release of DaemonTools, that contains SPTD v1.39 in it, it says "Current SPTD installation cannot be validated by setup" and suggest to disable SPTD service and reinstall it. If I would do this, I'll enter the reboot loop again.

                          Looks like you (Duplex Secure) have fixed the problem in latest release, but stupid DaemonTools installation program doesn't allow me to skip old SPTD installation. So I should bug DaemonTools support.

                          P.S. Sorry that replying via forum, not email. Don't have access to my mail from this box.

                          Comment


                          • #43
                            Oops! I was too fast to tell that everything is OK. After several minutes after boot, I see repeating error messages from sptd in event log. They are all same:

                            Code:
                            0000: 00 00 00 00 01 00 52 00   ......R.
                            0008: 00 00 00 00 04 00 04 c0   .......
                            0010: e7 00 00 00 89 45 fc b8   ...E
                            0018: 00 00 00 00 00 00 00 00   ........
                            0020: 00 00 00 00 00 00 00 00   ........
                            If I try to run SPTDinst-v142-x86.exe instead of "Uninstall" button I get the same message: ""Current SPTD installation cannot be validated by setup. ..."

                            Comment


                            • #44
                              btw, this message is logged every time I run SPTDinst-v142-x86.exe. It isn't logged spontaneously.

                              Comment


                              • #45
                                glebius:
                                You've some software running hooking system API calls that interferes with normal operation. Could be virus, rootkit, or some rootkit detection of uber-smart anti-virus.

                                Comment

                                Working...
                                X