No announcement yet.

SPTD Won't install - serious problems...

  • Filter
  • Time
  • Show
Clear All
new posts

  • SPTD Won't install - serious problems...

    I've had this problem a while now.

    First I had some old SPTD version, 1.2x, and it worked fine, used with Daemon Tools 4.0.3. Now I'd need the DT 4.0.8, which needs SPTD 1.38, but the SPTD won't install. Installer asks me to boot, and when I reboot, my computer locks down after the XP Loading logo. Then, I have to go through the safe mode and delete the sptd driver.

    Any of the older SPTD's won't install now. I've tried three or four different versions, and nothing. Always the same black screen when trying to reboot. I've tried with different Daemon Tools versions and the stand-alone SPTD installers, nothing solves the problem.

    My computer is Acer Aspire 5671 (laptop). I had this idea of the Logitech webcam being the cause of the problem, but I tried also without it and the problem still exists.

  • #2
    Please contact our support by mail (


    • #3
      Okay, will do!